YouTube Broken in Latest Microsoft Edge Build, and Here’s the Fix


The new Chromium-based Microsoft Edge browser is still a work-in-progress, but this doesn’t necessarily mean that many people out there aren’t already using it as their daily drivers.

This isn’t necessarily the best thing to do, especially because Canary and Dev builds of the browser are supposed to help Microsoft experiment with all kinds of ideas that may not make their way to the production builds.

In other words, if you run the Canary version of Microsoft Edge, for example, you kind of expect to hit bugs every now and then, and the only thing you can do is search for workarounds and send feedback to Microsoft to have the issue fixed before a new build is released.

This is what happened late last week when testers running Microsoft Ede Canary on their devices discovered that Google’s YouTube platform is no longer working correctly. As you can see in the screenshot here, YouTube does not load properly, and the content is scrambled on the page.

By the looks of things, this isn’t a problem that is specific to Microsoft Edge, as some users claim they encountered similar problems in other Chromium browsers, such as Google Chrome Canary (also an experimental browser that helps Google try out new improvements before they are released in the stable version of the app).

While Google has already resolved the bug in the latest Chrome Canary build, Microsoft is yet to release a fix, albeit I expect this to land any day now. Right now, here are the versions where the bug exists and where it’s already fixed:

Not fixed: Microsoft Edge Canary version 80.0.315.0

Fixed: Google Chrome Canary version 80.0.3951.0

In the meantime, while Microsoft is still working on a fix for the YouTube rendering bug, you can actually resolve the problem on your own by simply changing the user agent in the current Edge Canary build.

Doing this is super-easy, albeit one thing that you should know is that you need to change the user agent every time you load YouTube (e.g. after launching Microsoft Edge).

Changing the user agent in Microsoft Edge is just a matter of clicks.

First of all, head over to youtube.com and load the page even if it appears to be broken. Next, you need to follow these steps in Microsoft Edge:


Microsoft Edge Menu More tools Developer tools Menu More tools Network conditions

You should now see a User agent section with the option called Select automatically enabled. Disable this option and then from the drop-down menu, choose Firefox – Windows. YouTube should automatically refresh in the background and everything should be back to normal, with videos loading correctly. Keep in mind that these settings stay in place until you reboot the browser, so you’ll have to follow the same steps when you launch Microsoft Edge once again.

In the meantime, if you don’t want to do this every time you start Edge Canary, you can just switch to the Dev channel,…



Source link

Leave a Comment

Your email address will not be published. Required fields are marked *

Social media & sharing icons powered by UltimatelySocial
error

Enjoy this blog? Please spread the word :)